Why can't I send an onboarding package to an employee?
Issue
You cannot send an onboarding package to a new or re-hired employee even though the employee profile is visible in 7shifts.
Cause
This issue occurs if the employee profile is missing an active employment period. 7shifts requires an active employment period to recognize the employee as an active worker and trigger onboarding workflows. Additionally, this can occur if the Location settings are missing a valid address.
What to do
Add an active employment period
An active employment period must exist on the employee profile to send onboarding packages.
- Log into the 7shifts web app as an Admin.
- Navigate to the employee profile.
- Select the Employment tab.
- Locate the Employment History section.
- Click Add employment period to create a new active record for the employee.
Update Location address
The employee dropdown menu for onboarding packages may be unavailable if the Location address is missing or invalid.
- Log into the 7shifts web app as an Admin.
- Navigate to Settings Locations/Departments/Roles.
- Click the pencil icon next to the Location name.
- Select the General tab.
- Enter a valid address in the address fields and save your changes.