How to fix Overdue payroll after submitting it on time

Issue 

After running an off-cycle payroll, your regular payroll appears as Overdue in the Schedule tab—even though payroll was successfully submitted for that pay period.


Cause 

This behavior is typically caused by a payroll draft that remains open in the 7shifts account. If a draft is not cleared, the 7shifts account recognizes the period as incomplete and triggers the overdue notification.


What To Do

To clear the overdue status is to delete the lingering payroll draft:

  1. Log in to the web app as an Admin.

  2. In the left navigation bar, head to Payroll.

  3. Locate the draft of the payroll that is showing as overdue.

  4. Click the More Options icon (three dots) beside the payroll draft (labeled Run Payroll).

  5. Select Delete Payroll.

Note: Once deleted, the “Payroll Overdue” message will disappear after the system refreshes. You can wait for a few business days, and the display will likely correct itself. However, there is no exact timeline for when it will clear and display the next pay period

Issue Unresolved

If you need the next pay period to display immediately, contact us and let them know you need your pay schedule adjusted.

Browse our Help Center for self-guided resources on payroll reports, tip management, and more.

Didn't find the answers you were looking for? Log in to your account to start a chat with our Support team, or give us a call at 1-888-979-5877.

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