How to fix Overdue payroll after submitting it on time
Issue
After running an off-cycle payroll, your regular payroll appears as Overdue in the Schedule tab—even though payroll was successfully submitted for that pay period.
Cause
This behavior is typically caused by a payroll draft that remains open in the 7shifts account. If a draft is not cleared, the 7shifts account recognizes the period as incomplete and triggers the overdue notification.
What To Do
To clear the overdue status is to delete the lingering payroll draft:
Log in to the web app as an Admin.
In the left navigation bar, head to Payroll.
Locate the draft of the payroll that is showing as overdue.
Click the More Options icon (three dots) beside the payroll draft (labeled Run Payroll).
Select Delete Payroll.
Issue Unresolved
If you need the next pay period to display immediately, contact us and let them know you need your pay schedule adjusted.
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