System Requirements

In order to ensure the security of client data and to provide a smooth end user experience, you will need to ensure that your device's operating system and web browser satisfy the minimum requirements outlined below.

Desktop Operating system minimum requirements

  • Windows 7 (PC)
  • MacOS 10.10 (Yosemite)
⚠️ Connection via Windows Vista and Windows XP operating systems are shut off completely as they do not meet the minimum security requirements.

Web browser minimum requirements

Chrome 80+ (12+ on iOS mobile)
Safari 12+ (12+ on iOS mobile)
Firefox 80+ (12+ on iOS mobile)
Edge 80+
Internet Explorer Not supported
⚠️ You will need to upgrade your system/browser to meet these minimum requirements to access app.7shifts.com.

Mobile operating system minimum requirements

7shifts:

iOS 12.0+
Users can still use the app if they are on an older version of iOS, but they will need to update to iOS 12+ to continue to benefit from regular updates.
Android

5.0+

7punches:

iOS
12.0+
Users can still use the app if they are on an older version of iOS, but they will need to update to iOS 12+ to continue to benefit from regular updates.
Android
5.0+
Amazon Fire 5.0+

7tasks:

iOS
12.0+
Android
5.0+
 
⚠️ Tip: Users can also set up automatic updates for their devices and from their app store to ensure that they are running the latest software versions available.
Was this article helpful?
1 out of 2 found this helpful