Why is my 'Run payroll / Run off cycle payroll' button greyed out?

Issue

The Run payroll or Run off-cycle payroll button is greyed out in 7shifts Payroll, preventing the user from starting a payroll run.


Cause

This issue occurs when there is an active funding block on the 7shifts Payroll account.

  • A previously run payroll failed due to insufficient funds (NSF).
  • A mid-quarter collection or historical tax liability debit failed.
  • An ACH retry is currently in progress and has not yet cleared.

What to do

Important: If an ACH is retried after a failure, it typically takes at least three business days to clear.

To resolve the block, you must ensure all outstanding liabilities are funded.

  • Wait for the automated ACH retry to clear or fund the payroll via wire transfer to remove the block faster.
  • Contact 7shifts Support to coordinate payment if a Historical Liability Debit or Mid-Quarter Collection failed.
  • Check the 7shifts Payroll dashboard to confirm if any previous runs are marked as Failed or Funding.

 

Was this article helpful?
1 out of 2 found this helpful