Why is this Employee blocked and has no wage even though I have assigned them a wage?

Issue

An employee is blocked for 7shifts Payroll and does not show a wage, even though a wage was assigned in the employee profile.


Cause

This issue typically occurs if the wage effective date is set in the future, if there are assigned roles missing a wage, or if the payroll record requires a manual refresh to sync the latest profile changes.


What to do

Follow these steps to resolve the block and update the wage in 7shifts Payroll:

Check the effective wage date

  1. Navigate to Team and select Profile.
  2. Select Wages and Payment.
  3. Verify that the effective date is not set for a future date or in the middle of the current pay period.
  4. Re-save the effective date if changes are made.

Verify assigned roles

  1. Navigate to Team and select Profile.
  2. Select Assignments.
  3. Confirm that every assigned role has an associated wage rate.

Note: All assigned roles must have a wage rate even if the employee did not work that specific role during the current pay period.

Re-save the employee profile in 7shifts Payroll

  1. Navigate to Payroll and select Employees.
  2. Select the pencil icon next to the affected employee.
  3. Select Save.

 

 

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