Why can't I see an employee (previously an admin) on the schedule?
Issue
An employee does not appear on the schedule or won't stick to the scheduling roster even after they are assigned roles and have an active hire date. This typically occurs for users who were previously assigned the Admin user type and have recently transitioned to a Manager or employee role.
Cause
This behavior happens if the Appear as Employee setting was disabled while the user held an Admin user type. Because this setting is managed within an Admin user's private profile settings, the "hidden" status remains active even after their user type is changed, preventing them from being added to the schedule.
What To Do
To resolve this and make the user visible on the schedule, you must temporarily restore their access to toggle the internal setting.
Log in to the web app as the Account Owner.
Navigate to Team and select the employee's profile.
Change the User Type back to Admin > click Save.
Have the user log in to their 7shifts account.
The user must click on their profile picture and select My Account.
Check the box labeled Visible to team.
Click Save.
Log back into your Account Owner account and navigate to the Team page.
Re-assign the user to their correct role, such as Manager or Employee.
Navigate to the Schedule to add the employee to the roster.
Issue Unresolved
If the employee still does not appear after the user has enabled the Appear as Employee setting, please contact 7shifts Support with the employee's name and the specific location affected.